Error: Informix/onbar restore on UNIX/Linux fails with "*E* backup not found for:"

Last Updated: Apr 29, 2014 10:54PM CEST
Error: Informix/onbar restore on UNIX/Linux fails with "*E* backup not found for:"
NovaBACKUP DataCenter
Last Updated: Aug 28, 2013 10:31AM PDT
If the screen output of onbar -r shows

BSA_qr: Interrupted system call

and subsequently

*E* backup not found for: 27154:1327429857
Cause:

the reason might be the setting of the environment variables

BAR_ALARM
BAR_TEST_ALARM
BAR_TIMEOUT

To proof this, look into $INFORMIXDIR/tmp/bar_act.log.
If you find any "suspicious" time differences between the "successfully forked" Message
for a PID (here 8952) and the XBSA error Message for that PID, the timeout environment
variable setting is the reason. Example from bar_act.log:

2012-02-06 09:43:23 8952  8946 Process 8952  8946 successfully forked.
2012-02-06 09:43:23 8952  8946 Successfully connected to Storage Manager.
2012-02-06 09:47:23 8952  8946 XBSA Error: (BSAGetObject) This object has not been backed up.

The time difference is 240 seconds (09:47:23 minus 09:43:23 = 4 minutes), which is the Default
setting for all Informix timeout variables.
Looking at the setting of the environment variables

env | grep BAR

shows

BAR_ALARM=240
BAR_TEST_ALARM=240
BAR_TIMEOUT=240

Solution

The recommendation for the setting of the variables is 1200 (= 20 minutes).
Export the variable settings to the environment of the onbar call before you call it.
Example for Korn-Shell and BASH:

export BAR_ALARM=1200
export BAR_TEST_ALARM=1200
export BAR_TIMEOUT=1200
onbar -r
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